summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/knetstats/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/knetstats/debian')
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/cdbs/debian-qt-kde.mk6
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/cdbs/kde.mk4
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/cdbs/team-members16
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/control2
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/docs1
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/knetstats.1.docbook113
-rwxr-xr-xubuntu/maverick/applications/knetstats/debian/rules47
-rw-r--r--ubuntu/maverick/applications/knetstats/debian/watch3
10 files changed, 22 insertions, 285 deletions
diff --git a/ubuntu/maverick/applications/knetstats/debian/cdbs/buildvars.mk b/ubuntu/maverick/applications/knetstats/debian/cdbs/buildvars.mk
deleted file mode 100644
index 23d4709dc..000000000
--- a/ubuntu/maverick/applications/knetstats/debian/cdbs/buildvars.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2002,2003 Colin Walters <walters@debian.org>
-# Description: Defines some useful variables, but no rules
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_rules_buildvars
-_cdbs_rules_buildvars = 1
-
-CDBS_VERSION = something
-
-# Common useful variables
-DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
-
-# Split into arch/indep packages
-ifneq ($(DEB_INDEP_PACKAGES),cdbs)
-DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
-DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
-endif
-# Split into normal and udeb packages
-ifeq ($(DEB_UDEB_PACKAGES),)
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-else
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-endif
-# Too much bother for now. If someone complains we'll fix it.
-#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
-#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
-# A handy list of every package, udeb or not
-DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
-DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
-DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
-
-DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-
-# Some support for srcdir != builddir builds.
-# These are relative to the root of the package
-DEB_SRCDIR ?= .
-DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
-
-# Miscellaneous bits
-DEB_ARCH = $(shell dpkg --print-architecture)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
-DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-
-ifeq ($(words $(DEB_ALL_PACKAGES)),1)
- DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
-else
- DEB_DESTDIR = $(CURDIR)/debian/tmp/
-endif
-
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
-
-endif
diff --git a/ubuntu/maverick/applications/knetstats/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/knetstats/debian/cdbs/debian-qt-kde.mk
index 9920696ce..32ba4acfb 100644
--- a/ubuntu/maverick/applications/knetstats/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/knetstats/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,10 +19,11 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
+#include debian/cdbs/uploaders.mk
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
@@ -103,6 +105,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -111,6 +114,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/maverick/applications/knetstats/debian/cdbs/kde.mk b/ubuntu/maverick/applications/knetstats/debian/cdbs/kde.mk
index 765560c89..023886fc8 100644
--- a/ubuntu/maverick/applications/knetstats/debian/cdbs/kde.mk
+++ b/ubuntu/maverick/applications/knetstats/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
diff --git a/ubuntu/maverick/applications/knetstats/debian/cdbs/team-members b/ubuntu/maverick/applications/knetstats/debian/cdbs/team-members
deleted file mode 100644
index 05761af6e..000000000
--- a/ubuntu/maverick/applications/knetstats/debian/cdbs/team-members
+++ /dev/null
@@ -1,16 +0,0 @@
-Sune Vuorela <debian@pusling.com>
-Ana Beatriz Guerrero Lopez <ana@debian.org>
-Fathi Boudra <fboudra@free.fr>
-Modestas Vainius <geromanas@mailas.com>
-Josh Metzler <joshdeb@metzlers.org>
-Isaac Clerencia <isaac@debian.org>
-Adeodato Simó <dato@net.com.org.es>
-Adeodato Simo <dato@net.com.org.es>
-Christopher Martin <chrsmrtn@debian.org>
-Daniel Schepler <schepler@debian.org>
-Sarah Hobbs <hobbsee@ubuntu.com>
-Nacho Barrientos Arias <nacho@debian.org>
-Ricardo Javier Cardenes Medina <rcardenes@debian.org>
-Ricardo Cardenes <rcardenes@debian.org>
-Armin Berres <trigger+debian@space-based.de>
-Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/maverick/applications/knetstats/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/knetstats/debian/cdbs/uploaders.mk
deleted file mode 100644
index 31adfe31e..000000000
--- a/ubuntu/maverick/applications/knetstats/debian/cdbs/uploaders.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-
-MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
-
-
-debian/control.tmp:
- @if [ ! -e debian/control.in ] ; then \
- echo "this package is not yet prepared for using automatic update of uploaders"; \
- echo "Please do so."; \
- exit 1; \
- fi
- @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
-
-check-uploaders: debian/control.tmp
- @if ! diff -q debian/control debian/control.tmp ; then \
- echo "WARNING:: Control file differs from manually generated one" ; \
- echo "WARNING:: Please update it manually and check it afterwards" ; \
- echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
- echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
- fi
-
-
-clean::
- rm -f debian/control.tmp
-
-update-uploaders: debian/control.tmp
- @mv -f debian/control.tmp debian/control
-
-makebuilddir:: check-uploaders
diff --git a/ubuntu/maverick/applications/knetstats/debian/control b/ubuntu/maverick/applications/knetstats/debian/control
index a1c2b13e7..e4465d5e4 100644
--- a/ubuntu/maverick/applications/knetstats/debian/control
+++ b/ubuntu/maverick/applications/knetstats/debian/control
@@ -2,7 +2,7 @@ Source: knetstats-trinity
Section: tde
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, tdelibs14-trinity-dev, docbook2x, automake, autoconf, libtool, libltdl-dev
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, cmake, tdelibs14-trinity-dev
Standards-Version: 3.8.4
Homepage: http://knetstats.sourceforge.net/
diff --git a/ubuntu/maverick/applications/knetstats/debian/docs b/ubuntu/maverick/applications/knetstats/debian/docs
new file mode 100644
index 000000000..e845566c0
--- /dev/null
+++ b/ubuntu/maverick/applications/knetstats/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/ubuntu/maverick/applications/knetstats/debian/knetstats.1.docbook b/ubuntu/maverick/applications/knetstats/debian/knetstats.1.docbook
deleted file mode 100644
index 3746cb991..000000000
--- a/ubuntu/maverick/applications/knetstats/debian/knetstats.1.docbook
+++ /dev/null
@@ -1,113 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
-"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
-]>
-<refentry>
- <refentryinfo>
- <author>
- <firstname>Mercatante</firstname>
- <surname>Anthony</surname>
- <email>tonio@ubuntu.com</email>
- </author>
- <copyright>
- <year>2006</year>
- <holder>Anthony Mercatante</holder>
- </copyright>
- <!-- XXX IMPORTANT XXX -->
- <!-- Keep this date up to date: -->
- <date>2006-09-27</date>
- <!-- ^^^^^^^^^^ -->
- </refentryinfo>
- <refmeta>
- <refentrytitle>knetstats</refentrytitle>
- <manvolnum>1</manvolnum>
- </refmeta>
- <refnamediv>
- <refname>knetstats</refname>
- <refpurpose>network interfaces monitor for TDE's systray</refpurpose>
- </refnamediv>
- <refsynopsisdiv>
- <cmdsynopsis>
- <command>knetstats</command>
- <arg choice="opt">
- <option><replaceable>Qt-options</replaceable></option>
- </arg>
- <arg choice="opt">
- <option><replaceable>TDE-options</replaceable></option>
- </arg>
- </cmdsynopsis>
- </refsynopsisdiv>
- <refsect1>
- <title>DESCRIPTION</title>
- <para>
- network interfaces monitor for TDE's systray.
- </para>
- <para>
- Knetstats is a simple TDE network monitor that show rx/tx LEDs of any network interface on a system tray icon
- </para>
- </refsect1>
- <refsect1>
- <title>OPTIONS</title>
- <para>
- All <productname>TDE</productname> and <productname>Qt</productname>
- programs accept a some common command-line options. Password Manager has no
- application-specific options.
- </para>
- <para>
- <variablelist>
- <title>Generic options:</title>
- <varlistentry>
- <term> <option>--help</option> </term>
- <listitem> <para>Show help about options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--help-qt</option> </term>
- <listitem> <para>Show Qt specific options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--help-tde</option> </term>
- <listitem> <para>Show TDE specific options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--help-all</option> </term>
- <listitem> <para>Show all options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--author</option> </term>
- <listitem> <para>Show author information</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>-v</option>, <option>--version</option> </term>
- <listitem> <para>Show version information</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--license</option> </term>
- <listitem> <para>Show license information</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--</option> </term>
- <listitem> <para>Indicates end of options</para> </listitem>
- </varlistentry>
- </variablelist>
- <!-- TODO * add all the rest of the options, but maybe find an automated
- way to keep it up to date -->
- </para>
- </refsect1>
- <refsect1>
- <title>COPYRIGHT</title>
- <para>
- This manual page was written by Anthony Mercatante
- <email>tonio@ubuntu.com</email> for the
- <productname>Debian</productname> system (but may be used by others).
- Permission is granted to copy, distribute and/or modify this document
- under the terms of the <acronym>GNU</acronym> General Public License,
- Version 2 or any later version published by the Free Software Foundation.
- </para>
- <para>
- On Debian systems, the complete text of the GNU General Public
- License can be found in
- <filename>/usr/share/common-licenses/GPL</filename>.
- </para>
- </refsect1>
-</refentry>
-
diff --git a/ubuntu/maverick/applications/knetstats/debian/rules b/ubuntu/maverick/applications/knetstats/debian/rules
index e0cb7dd6e..18b1c07e2 100755
--- a/ubuntu/maverick/applications/knetstats/debian/rules
+++ b/ubuntu/maverick/applications/knetstats/debian/rules
@@ -1,43 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include debian/cdbs/kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_MANPAGES_knetstats-trinity = knetstats.1
+include debian/cdbs/debian-qt-kde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-build/knetstats-trinity::
- docbook2x-man debian/knetstats.1.docbook
-
-binary-install/knetstats-trinity::
- mv debian/knetstats-trinity/usr/share/man debian/knetstats-trinity/opt/trinity/share/
-
-clean::
- rm -f knetstats.1
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/maverick/applications/knetstats/debian/watch b/ubuntu/maverick/applications/knetstats/debian/watch
deleted file mode 100644
index 8d12f40b0..000000000
--- a/ubuntu/maverick/applications/knetstats/debian/watch
+++ /dev/null
@@ -1,3 +0,0 @@
-version=3
-
-http://sf.net/knetstats/knetstats-(.*)\.tar\.bz2