summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/krename/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/krename/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/krename/debian/rules37
1 files changed, 37 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/krename/debian/rules b/ubuntu/maverick/applications/krename/debian/rules
new file mode 100755
index 000000000..ece39aee4
--- /dev/null
+++ b/ubuntu/maverick/applications/krename/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+### Libtool and Automake updates
+post-patches:: debian/stamp-autothings-update
+debian/stamp-autothings-update:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ for f in /usr/share/automake-1.10/*; do \
+ if test -f $$f && \
+ test -f $(DEB_SRCDIR)/admin/`basename $$f`; then \
+ cp -f $$f $(DEB_SRCDIR)/admin; \
+ fi; \
+ done
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+ touch $@