summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/ksplash-engine-moodin/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/ksplash-engine-moodin/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/ksplash-engine-moodin/debian/rules138
1 files changed, 138 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/ksplash-engine-moodin/debian/rules b/ubuntu/maverick/applications/ksplash-engine-moodin/debian/rules
new file mode 100755
index 000000000..2b5a4f326
--- /dev/null
+++ b/ubuntu/maverick/applications/ksplash-engine-moodin/debian/rules
@@ -0,0 +1,138 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+-include debian/debiandirs
+
+# To be used with kde-style admin subdirectories if desired.
+debian/debiandirs: admin/debianrules
+ perl -w admin/debianrules echodirs > debian/debiandirs
+
+patch-stamp:
+ # Apply Debian specific patches
+ if test ! -f patch-stamp; then \
+ for patch in $(CURDIR)/debian/patches/*.diff ;\
+ do \
+ echo APPLYING PATCH\: $${patch##*/};\
+ patch -p1 < $$patch ;\
+ done ;\
+ touch patch-stamp ;\
+ fi
+
+patch: patch-stamp
+
+config.status: configure patch
+ dh_testdir
+
+ CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(configkde) --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+ $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+ -$(MAKE) distclean
+
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+
+ # Remove Debian specific patches
+ if test -f patch-stamp; then \
+ for patch in $(CURDIR)/debian/patches/*.diff ;\
+ do \
+ echo REMOVING PATCH\: $${patch##*/};\
+ patch -p1 -R < $$patch ;\
+ done ;\
+ rm -f patch-stamp ;\
+ fi
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/ksplash-engine-moodin-trinity
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_installexamples
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress -X.bz2 -X.css -X.dcl -X.docbook -X-license -X.tag
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install