summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-sword/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-sword/debian')
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/cdbs/kde.mk91
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/changelog44
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/compat1
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/control20
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/copyright28
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/docs4
-rwxr-xr-xubuntu/maverick/applications/tdeio-sword/debian/rules20
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/source/format1
-rw-r--r--ubuntu/maverick/applications/tdeio-sword/debian/source/options6
11 files changed, 0 insertions, 353 deletions
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index 60310a01a..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,119 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/kde.mk b/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/kde.mk
deleted file mode 100644
index 80176d63e..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,91 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/versions.pl b/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/changelog b/ubuntu/maverick/applications/tdeio-sword/debian/changelog
deleted file mode 100644
index 1a73990b7..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/changelog
+++ /dev/null
@@ -1,44 +0,0 @@
-tdeio-sword-trinity (0.3-0ubuntu1) feisty; urgency=low
-
- * Initial Release for TDE
-
- -- Slávek Banko <slavek.banko@axis.cz> Wed, 21 Aug 2013 19:28:29 +0200
-
-kio-sword (0.3-0ubuntu1) feisty; urgency=low
-
- * New upstream version
- * Remove upstream debian/ dir to remake the orig tarball
-
- -- Raphael Pinson <raphink@ubuntu.com> Mon, 15 Jan 2007 19:32:56 +0100
-
-kio-sword (0.2-0ubuntu2) edgy; urgency=low
-
- * Rebuild with libsword6
-
- -- Raphaël Pinson <raphink@ichthux.com> Thu, 28 Sep 2006 23:15:09 +0200
-
-kio-sword (0.2-0ubuntu1) edgy; urgency=low
-
- * New upstream version
- * Remove old debian/ directory from source
- * Copy sword_1_5_8_fix.patch to debian/patches
- * Bump debhelper version, compat level and standards version
-
- -- Raphaël Pinson <raphink@ubuntu.com> Tue, 18 Jul 2006 19:03:21 -0400
-
-kio-sword (0.1-0ubuntu2) dapper; urgency=low
-
- * Rebuild for dh_iconcache
-
- -- Brandon Holtsclaw <brandon@imbrandon.com> Tue, 23 May 2006 16:46:03 +0000
-
-kio-sword (0.1-0ubuntu1) dapper; urgency=low
-
- * Initial release.
- * Removed old debian/ directory.
- * Removed admin/CVS directory.
- * Patch kubuntu_01_strcmp_var.patch fixes stricmp to strcmp variable in csword.cpp, ks_osishtml.cpp
- and ks_thmlhtml.cpp to have kio-sword compile with latest sword libraries.
-
- -- Raphaël Pinson <raphink@raphink.net> Thu, 17 Nov 2005 17:16:56 +0100
-
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/compat b/ubuntu/maverick/applications/tdeio-sword/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/control b/ubuntu/maverick/applications/tdeio-sword/debian/control
deleted file mode 100644
index 7e7340fe9..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/control
+++ /dev/null
@@ -1,20 +0,0 @@
-Source: tdeio-sword-trinity
-Section: tde
-Priority: extra
-Maintainer: Raphaël Pinson <raphink@raphink.net>
-Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, cmake, libsword-dev (>= 1.5.8-1), tdelibs14-trinity-dev
-Standards-Version: 3.7.2
-
-Package: tdeio-sword-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, konqueror
-Suggests: sword-text, sword-dict, sword-comm
-Provides: sword-frontend
-Description: tdeio-slave for the Sword Bible tool
- TDEio-Sword provides access to Bibles, commentaries
- and other texts in an easy to use and attractive
- interface -- the Konqueror web browser. It does so
- using the SWORD Bible project and implementing a TDE
- ioslave, providing the sword:/ protocol.
- .
- http://lukeplant.me.uk/kio-sword/
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/copyright b/ubuntu/maverick/applications/tdeio-sword/debian/copyright
deleted file mode 100644
index ed21e28ca..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/copyright
+++ /dev/null
@@ -1,28 +0,0 @@
-This package was debianized by Raphaël Pinson <raphink@raphink.net> on
-Thu, 17 Nov 2005 17:16:56 +0100.
-
-It was downloaded from http://lukeplant.me.uk/kio-sword/downloads/kio_sword-0.1.tar.gz
-
-Upstream Author : Luke Plant <L.Plant.98@cantab.net>
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- On Debian GNU/Linux systems, the complete text of the GNU General
- Public License can be found in `/usr/share/common-licenses/GPL'.
-
-Copyright
-
-All the software:
-
- (C) 2004-2005 by Luke Plant <L.Plant.98@cantab.net>
-
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/docs b/ubuntu/maverick/applications/tdeio-sword/debian/docs
deleted file mode 100644
index c17f03764..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/docs
+++ /dev/null
@@ -1,4 +0,0 @@
-AUTHORS
-NEWS
-README
-TODO
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/rules b/ubuntu/maverick/applications/tdeio-sword/debian/rules
deleted file mode 100755
index 18b1c07e2..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/rules
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include debian/cdbs/debian-qt-kde.mk
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/source/format b/ubuntu/maverick/applications/tdeio-sword/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/maverick/applications/tdeio-sword/debian/source/options b/ubuntu/maverick/applications/tdeio-sword/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/maverick/applications/tdeio-sword/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*