summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/krecipes/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/krecipes/debian/rules')
-rwxr-xr-xubuntu/precise/applications/krecipes/debian/rules40
1 files changed, 0 insertions, 40 deletions
diff --git a/ubuntu/precise/applications/krecipes/debian/rules b/ubuntu/precise/applications/krecipes/debian/rules
deleted file mode 100755
index 3d278aa58..000000000
--- a/ubuntu/precise/applications/krecipes/debian/rules
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-binary-install/krecipes-trinity::
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg)
-
-binary-install/krecipes-data-trinity::
- dh_testdir
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap