summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/precise/dependencies/tqtinterface/debian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/ubuntu/precise/dependencies/tqtinterface/debian/rules b/ubuntu/precise/dependencies/tqtinterface/debian/rules
index f05e2fadd..5d8f4cb4c 100755
--- a/ubuntu/precise/dependencies/tqtinterface/debian/rules
+++ b/ubuntu/precise/dependencies/tqtinterface/debian/rules
@@ -14,6 +14,9 @@ DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
DEB_CMAKE_EXTRA_FLAGS := -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_LIBRARY_PATH="/usr/lib" -DCMAKE_INCLUDE_PATH="/usr/include" -DCMAKE_VERBOSE_MAKEFILE="ON" -DWITH_QT3="ON" -DQTDIR="/usr/share/qt3" -DQT_LIBRARY_DIRS="/usr/share/qt3/lib" -DBUILD_ALL="ON" -DUSE_QT3="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
DEB_BUILD_PARALLEL = true