summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-03-31 16:13:43 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-03-31 16:33:53 +0200
commit789538268f2ee359423ee509e712ae18638ab3a9 (patch)
tree5a3753939eca71e30aecd0866012fd4be81a6d2d /CMakeLists.txt
parent26ee115d569391bac2c6e2b4772ccb3de012ecdd (diff)
downloadtde-style-lipstik-789538268f2ee359423ee509e712ae18638ab3a9.tar.gz
tde-style-lipstik-789538268f2ee359423ee509e712ae18638ab3a9.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 283aebe0015ee5527dc322dde90237922b351109)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a66f656..b919205 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )