summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-29 19:41:28 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-01-26 15:37:01 +0100
commitf11f6d6ded39175d915422da2bac6fb6ffc924f9 (patch)
tree8a281ef5def0c82ebf101a1229ed52d85f623852 /CMakeLists.txt
parent7eca1e554ec80ab1d36bb93834fc8b0a161be3b1 (diff)
downloadtdeaccessibility-f11f6d6ded39175d915422da2bac6fb6ffc924f9.tar.gz
tdeaccessibility-f11f6d6ded39175d915422da2bac6fb6ffc924f9.zip
Conversion to the cmake building system.
Added several man pages taken from the Debian packaging. Cleanup headers in ui files. Add png icons for mono theme. Signed-off-by: gregory guy <gregory-tde@laposte.net> cmake: - Use tde_add_check_executable instead of a combination of separate calls to tde_add_executable and add_test. - Simplify the detection of time.h and sys/time.h headers. - Refactor phrasebook files install, kmouth. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 6b3181cf92f1fc74da1e8a82f690a1526cb4e900)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt117
1 files changed, 117 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ef8985f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,117 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+cmake_minimum_required( VERSION 2.8.12 )
+
+
+#### general package setup
+
+project( tdeaccessibility )
+set( VERSION R14.1.0 )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckIncludeFiles )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
+
+
+#### include our cmake modules
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+enable_testing( )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" ON )
+option( WITH_AKODE "Enable akode support" ${WITH_ALL_OPTIONS} )
+option( WITH_ALSA "Enable alsa support" ${WITH_ALL_OPTIONS} )
+option( WITH_GSTREAMER "Enable Gstreamer support" OFF )
+
+########################################################################
+# #
+# aRts support is needed to build: #
+# - kttsd artsplayer #
+# - ksayit #
+# - ksayit freeverb plugin #
+# #
+########################################################################
+
+
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+
+option( BUILD_KBSTATEAPPLET "Build kbstateapplet" ${BUILD_ALL} )
+option( BUILD_KMAG "Build kmag" ${BUILD_ALL} )
+option( BUILD_KMOUSETOOL "Build kmousetool" ${BUILD_ALL} )
+option( BUILD_KMOUTH "Build kmouth" ${BUILD_ALL} )
+option( BUILD_KSAYIT "Build ksayit" ${BUILD_ALL} )
+option( BUILD_KSAYIT_FREEVERB "Build ksayit freeverb plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD "Build kttsd" ${BUILD_ALL} )
+option( BUILD_KTTSD_COMMAND "Build kttsd command plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD_EPOS "Build kttsd epos plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD_FESTIVAL "Build kttsd festival plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD_FLITE "Build kttsd flite plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD_FREETTS "Build kttsd freetts plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD_HADIFIX "Build kttsd hadifix plugin" ${BUILD_ALL} )
+option( BUILD_KTTSD_KATE "Build kttsd kate plugin" ${BUILD_ALL} )
+option( BUILD_ICONTHEMES "Build icons" ${BUILD_ALL} )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+tde_conditional_add_subdirectory( BUILD_KBSTATEAPPLET kbstateapplet )
+tde_conditional_add_subdirectory( BUILD_KMAG kmag )
+tde_conditional_add_subdirectory( BUILD_KMOUSETOOL kmousetool )
+tde_conditional_add_subdirectory( BUILD_KMOUTH kmouth )
+tde_conditional_add_subdirectory( BUILD_KSAYIT ksayit )
+tde_conditional_add_subdirectory( BUILD_KTTSD kttsd )
+tde_conditional_add_subdirectory( BUILD_ICONTHEMES IconThemes )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+
+if( BUILD_KSAYIT OR BUILD_KTTSD )
+ add_subdirectory( kspeechsink )
+endif()
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )