summaryrefslogtreecommitdiffstats
path: root/kmouth/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-29 19:41:28 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-01-26 15:37:01 +0100
commitf11f6d6ded39175d915422da2bac6fb6ffc924f9 (patch)
tree8a281ef5def0c82ebf101a1229ed52d85f623852 /kmouth/CMakeLists.txt
parent7eca1e554ec80ab1d36bb93834fc8b0a161be3b1 (diff)
downloadtdeaccessibility-f11f6d6ded39175d915422da2bac6fb6ffc924f9.tar.gz
tdeaccessibility-f11f6d6ded39175d915422da2bac6fb6ffc924f9.zip
Conversion to the cmake building system.
Added several man pages taken from the Debian packaging. Cleanup headers in ui files. Add png icons for mono theme. Signed-off-by: gregory guy <gregory-tde@laposte.net> cmake: - Use tde_add_check_executable instead of a combination of separate calls to tde_add_executable and add_test. - Simplify the detection of time.h and sys/time.h headers. - Refactor phrasebook files install, kmouth. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 6b3181cf92f1fc74da1e8a82f690a1526cb4e900)
Diffstat (limited to 'kmouth/CMakeLists.txt')
-rw-r--r--kmouth/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/kmouth/CMakeLists.txt b/kmouth/CMakeLists.txt
new file mode 100644
index 0000000..9fec611
--- /dev/null
+++ b/kmouth/CMakeLists.txt
@@ -0,0 +1,63 @@
+add_subdirectory( icons )
+add_subdirectory( phrasebook )
+add_subdirectory( wordcompletion )
+add_subdirectory( books )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/kmouth/phrasebook
+ ${CMAKE_BINARY_DIR}/kmouth/wordcompletion
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kmouth (executable)
+
+tde_add_executable( kmouth AUTOMOC
+
+ SOURCES
+ preferencesui.ui
+ texttospeechconfigurationui.ui
+ texttospeechconfigurationwidget.cpp
+ optionsdialog.cpp
+ configwizard.cpp
+ phraseedit.cpp
+ phraselist.cpp
+ speech.cpp
+ texttospeechsystem.cpp
+ phraselistitem.cpp
+ kmouth.cpp
+ main.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ tdeprint-shared
+ phrasebook-static
+ wordcompletion-static
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kmouthui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kmouth
+)
+
+install(
+ FILES kmouthrc
+ DESTINATION ${CONFIG_INSTALL_DIR}
+)
+
+tde_create_translated_desktop( kmouth.desktop )