summaryrefslogtreecommitdiffstats
path: root/kttsd/kttsjobmgr/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit00bb99ac80741fc50ef8a289719373032f2391eb (patch)
tree3a5a9bf72f942784b38bf77dd66c534662fab5f2 /kttsd/kttsjobmgr/Makefile.am
downloadtdeaccessibility-00bb99ac80741fc50ef8a289719373032f2391eb.tar.gz
tdeaccessibility-00bb99ac80741fc50ef8a289719373032f2391eb.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaccessibility@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kttsd/kttsjobmgr/Makefile.am')
-rw-r--r--kttsd/kttsjobmgr/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/kttsd/kttsjobmgr/Makefile.am b/kttsd/kttsjobmgr/Makefile.am
new file mode 100644
index 0000000..98727e0
--- /dev/null
+++ b/kttsd/kttsjobmgr/Makefile.am
@@ -0,0 +1,40 @@
+# Include paths. INCLUDES is maintained by KDevelop, AM_CPPFLAGS is the preferred variable,
+# so keep them synchronized.
+INCLUDES = \
+ -I$(top_srcdir)/kttsd/libkttsd -I$(top_builddir)/kttsd/libkttsd \
+ $(KTTS_KSPEECH_INCLUDE) \
+ $(all_includes)
+
+# Let automoc handle all of the metsource files (moc).
+METASOURCES = AUTO
+
+#########################################################################
+# KPART SECTION
+#########################################################################
+# This is the kpart that gets installed. It's name is used for all
+# of the other Makefile.am variables.
+kde_module_LTLIBRARIES = libkttsjobmgrpart.la
+
+kspeech_DIR = $(KTTS_KSPEECH_DIR)
+kspeechsink_DIR = $(KTTS_KSPEECH_DIR)
+
+# The source, library search path, and link libraries.
+libkttsjobmgrpart_la_SOURCES = \
+ kspeech.stub kspeechsink.skel \
+ kttsjobmgr.cpp
+
+libkttsjobmgrpart_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries) $(KDE_PLUGIN)
+libkttsjobmgrpart_la_LIBADD = \
+ $(top_builddir)/kttsd/libkttsd/libkttsd.la \
+ $(LIB_KFILE) $(LIBVM) $(LIB_KPARTS)
+
+# Header files not to be installed.
+noinst_HEADERS =
+
+# Install desktop file to standard services directory.
+kde_services_DATA = kttsjobmgr.desktop
+
+# This rc file should never have been installed.
+# createGUI not supported within a KCModule.
+install-data-local:
+ rm -f $(DESTDIR)$(kde_datadir)/kttsjobmgr/kttsjobmgrui.rc