summaryrefslogtreecommitdiffstats
path: root/kttsd/kttsmgr/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit00bb99ac80741fc50ef8a289719373032f2391eb (patch)
tree3a5a9bf72f942784b38bf77dd66c534662fab5f2 /kttsd/kttsmgr/Makefile.am
downloadtdeaccessibility-00bb99ac80741fc50ef8a289719373032f2391eb.tar.gz
tdeaccessibility-00bb99ac80741fc50ef8a289719373032f2391eb.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaccessibility@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kttsd/kttsmgr/Makefile.am')
-rw-r--r--kttsd/kttsmgr/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/kttsd/kttsmgr/Makefile.am b/kttsd/kttsmgr/Makefile.am
new file mode 100644
index 0000000..747408d
--- /dev/null
+++ b/kttsd/kttsmgr/Makefile.am
@@ -0,0 +1,34 @@
+# Include paths.
+INCLUDES = \
+ $(KTTS_KSPEECH_INCLUDE) \
+ $(all_includes)
+
+# Let automoc handle all of the metsource files (moc).
+METASOURCES = AUTO
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# This is the program that gets installed. It's name is used for all
+# of the other Makefile.am variables.
+bin_PROGRAMS = kttsmgr
+
+kspeech_DIR = $(KTTS_KSPEECH_DIR)
+kspeechsink_DIR = $(KTTS_KSPEECH_DIR)
+
+# The source, library search path, and link libraries.
+kttsmgr_SOURCES = \
+ kspeech.stub \
+ kspeechsink.skel \
+ kttsmgr.cpp
+
+kttsmgr_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kttsmgr_LDADD = \
+ $(LIB_KUTILS) \
+ $(LIB_KDEUI)
+
+# Header files that should not be installed.
+noinst_HEADERS = kttsmgr.h
+
+# K Menu entry.
+xdg_apps_DATA = kttsmgr.desktop