summaryrefslogtreecommitdiffstats
path: root/kttsd/players/akodeplayer/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-29 19:41:28 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-01-26 15:37:01 +0100
commitf11f6d6ded39175d915422da2bac6fb6ffc924f9 (patch)
tree8a281ef5def0c82ebf101a1229ed52d85f623852 /kttsd/players/akodeplayer/CMakeLists.txt
parent7eca1e554ec80ab1d36bb93834fc8b0a161be3b1 (diff)
downloadtdeaccessibility-f11f6d6ded39175d915422da2bac6fb6ffc924f9.tar.gz
tdeaccessibility-f11f6d6ded39175d915422da2bac6fb6ffc924f9.zip
Conversion to the cmake building system.
Added several man pages taken from the Debian packaging. Cleanup headers in ui files. Add png icons for mono theme. Signed-off-by: gregory guy <gregory-tde@laposte.net> cmake: - Use tde_add_check_executable instead of a combination of separate calls to tde_add_executable and add_test. - Simplify the detection of time.h and sys/time.h headers. - Refactor phrasebook files install, kmouth. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 6b3181cf92f1fc74da1e8a82f690a1526cb4e900)
Diffstat (limited to 'kttsd/players/akodeplayer/CMakeLists.txt')
-rw-r--r--kttsd/players/akodeplayer/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/kttsd/players/akodeplayer/CMakeLists.txt b/kttsd/players/akodeplayer/CMakeLists.txt
new file mode 100644
index 0000000..f8a03f7
--- /dev/null
+++ b/kttsd/players/akodeplayer/CMakeLists.txt
@@ -0,0 +1,37 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/kttsd/libkttsd
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### libkttsd_akodeplugin (kpart)
+
+tde_add_kpart( libkttsd_akodeplugin AUTOMOC
+
+ SOURCES
+ akodeplugin.cpp
+ akodeplayer.cpp
+ LINK
+ kttsd-shared
+ ${AKODE_LIBRARIES}
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+tde_create_translated_desktop(
+ SOURCE kttsd_akodeplugin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)