summaryrefslogtreecommitdiffstats
path: root/kmouth/phrasebook/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kmouth/phrasebook/CMakeLists.txt')
-rw-r--r--kmouth/phrasebook/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/kmouth/phrasebook/CMakeLists.txt b/kmouth/phrasebook/CMakeLists.txt
new file mode 100644
index 0000000..ed96605
--- /dev/null
+++ b/kmouth/phrasebook/CMakeLists.txt
@@ -0,0 +1,31 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### phrasebook (static)
+
+tde_add_library( phrasebook STATIC_PIC AUTOMOC
+
+ SOURCES
+ buttonboxui.ui
+ phrasetree.cpp
+ phrasebookparser.cpp
+ phrasebookdialog.cpp
+ phrasebook.cpp
+)
+
+
+install(
+ FILES phrasebookdialogui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kmouth
+)