summaryrefslogtreecommitdiffstats
path: root/kttsd/libkttsd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kttsd/libkttsd/Makefile.am')
-rw-r--r--kttsd/libkttsd/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/kttsd/libkttsd/Makefile.am b/kttsd/libkttsd/Makefile.am
new file mode 100644
index 0000000..3b2c099
--- /dev/null
+++ b/kttsd/libkttsd/Makefile.am
@@ -0,0 +1,45 @@
+# Include paths.
+INCLUDES = $(all_includes)
+
+# Let automoc handle all of the metsource files (moc).
+METASOURCES = AUTO
+
+#########################################################################
+# LIBRARY SECTION
+#########################################################################
+# This is the library that gets installed. It's name is used for all
+# of the other Makefile.am variables.
+lib_LTLIBRARIES = libkttsd.la
+
+# The source, library search path, and link libraries.
+libkttsd_la_SOURCES = \
+ pluginproc.cpp \
+ pluginconf.cpp \
+ testplayer.cpp \
+ stretcher.cpp \
+ talkercode.cpp \
+ filterproc.cpp \
+ filterconf.cpp \
+ utils.cpp \
+ selecttalkerdlg.cpp \
+ selecttalkerwidget.ui \
+ notify.cpp
+
+libkttsd_la_LDFLAGS = -version-info 1:0:0 $(all_libraries) -no-undefined
+libkttsd_la_LIBADD = $(LIB_KIO)
+
+# Header files that should not be installed.
+noinst_HEADERS = \
+ pluginproc.h \
+ pluginconf.h \
+ player.h \
+ testplayer.h \
+ stretcher.h \
+ talkercode.h \
+ utils.h \
+ kdeexportfix.h \
+ selecttalkerdlg.h
+
+# This library is installed as a service.
+servicetypes_DATA = kttsd_synthplugin.desktop
+servicetypesdir = $(kde_servicetypesdir)