summaryrefslogtreecommitdiffstats
path: root/kttsd/plugins/epos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kttsd/plugins/epos/Makefile.am')
-rw-r--r--kttsd/plugins/epos/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kttsd/plugins/epos/Makefile.am b/kttsd/plugins/epos/Makefile.am
new file mode 100644
index 0000000..8f40ca7
--- /dev/null
+++ b/kttsd/plugins/epos/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = \
+ -I$(top_srcdir)/kttsd/libkttsd -I$(top_builddir)/kttsd/libkttsd \
+ $(all_includes)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = libkttsd_eposplugin.la
+
+libkttsd_eposplugin_la_SOURCES = \
+ eposconfwidget.ui \
+ eposconf.cpp \
+ eposproc.cpp \
+ eposplugin.cpp
+libkttsd_eposplugin_la_LDFLAGS = $(KDE_PLUGIN) $(all_libraries)
+libkttsd_eposplugin_la_LIBADD = $(top_builddir)/kttsd/libkttsd/libkttsd.la
+
+services_DATA = kttsd_eposplugin.desktop
+servicesdir = $(kde_servicesdir)
+
+noinst_HEADERS = eposproc.h eposconf.h eposconfwidget.h