summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-08-25 15:20:08 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-01 18:41:35 +0200
commit4aae8e03369bf188b6300f75745e6cc837889157 (patch)
tree1acf77e4bce6499e6568530e857658f0cb2ae726 /CMakeLists.txt
parent48c6bba031ea37591a821d9554dd292aee938d58 (diff)
downloadtdeadmin-4aae8e03369bf188b6300f75745e6cc837889157.tar.gz
tdeadmin-4aae8e03369bf188b6300f75745e6cc837889157.zip
cmake: Add option for GCC hidden visibility
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e4f81c..425070e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,7 +38,8 @@ tde_setup_paths( )
##### optional stuff ############################
-
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules #####