summaryrefslogtreecommitdiffstats
path: root/kdat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdat/CMakeLists.txt')
-rw-r--r--kdat/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/kdat/CMakeLists.txt b/kdat/CMakeLists.txt
new file mode 100644
index 0000000..4adf4fb
--- /dev/null
+++ b/kdat/CMakeLists.txt
@@ -0,0 +1,39 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kdat (executable) #########################
+
+tde_add_executable( kdat AUTOMOC
+ SOURCES Archive.cpp ArchiveInfoWidget.cpp BackupDlg.cpp BackupOptDlg.cpp
+ BackupProfile.cpp BackupProfileInfoWidget.cpp BackupProfileManager.cpp
+ BackupProfileWidget.cpp ErrorHandler.cpp File.cpp FileInfoWidget.cpp
+ ImageCache.cpp IndexDlg.cpp InfoShellWidget.cpp KDatMainWindow.cpp
+ LoggerWidget.cpp Node.cpp Options.cpp OptionsDlg.cpp OptionsDlgWidget.ui
+ Range.cpp Tape.cpp TapeDrive.cpp TapeFileInfoWidget.cpp TapeInfoWidget.cpp
+ TapeManager.cpp FormatOptDlg.cpp TarParser.cpp Util.cpp VerifyDlg.cpp
+ VerifyOptDlg.cpp ktreeview.cpp main.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES kdat.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)