summaryrefslogtreecommitdiffstats
path: root/lilo-config/kde/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lilo-config/kde/CMakeLists.txt')
-rw-r--r--lilo-config/kde/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/lilo-config/kde/CMakeLists.txt b/lilo-config/kde/CMakeLists.txt
new file mode 100644
index 0000000..49b1059
--- /dev/null
+++ b/lilo-config/kde/CMakeLists.txt
@@ -0,0 +1,32 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/lilo-config/kde-qt-common
+ ${CMAKE_SOURCE_DIR}/lilo-config/common/
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kcm_lilo (kpart) ##########################
+
+tde_add_kpart( kcm_lilo AUTOMOC
+ SOURCES kcontrol.cpp Details.cpp InputBox.cpp
+ LINK tdeio-shared tdecore-shared tdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES lilo.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)