summaryrefslogtreecommitdiffstats
path: root/kwin-styles/cde/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kwin-styles/cde/config/CMakeLists.txt')
-rw-r--r--kwin-styles/cde/config/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/kwin-styles/cde/config/CMakeLists.txt b/kwin-styles/cde/config/CMakeLists.txt
new file mode 100644
index 00000000..5c5427b1
--- /dev/null
+++ b/kwin-styles/cde/config/CMakeLists.txt
@@ -0,0 +1,28 @@
+#################################################
+#
+# (C) 2011 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### kwin_cde_config (module) ###################
+
+tde_add_kpart( kwin_cde_config AUTOMOC
+ SOURCES config.cpp
+ LINK kdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)