summaryrefslogtreecommitdiffstats
path: root/kwin-styles/riscos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kwin-styles/riscos/CMakeLists.txt')
-rw-r--r--kwin-styles/riscos/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/kwin-styles/riscos/CMakeLists.txt b/kwin-styles/riscos/CMakeLists.txt
new file mode 100644
index 00000000..470b6f9f
--- /dev/null
+++ b/kwin-styles/riscos/CMakeLists.txt
@@ -0,0 +1,52 @@
+#################################################
+#
+# (C) 2011 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ -DQT_PLUGIN
+)
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES riscos.desktop DESTINATION ${DATA_INSTALL_DIR}/kwin )
+
+##### kwin3_riscos ###############################
+
+
+set( target kwin3_riscos )
+
+set( ${target}_SRCS
+ AboveButton.cpp Button.cpp
+ CloseButton.cpp
+ HelpButton.cpp
+ IconifyButton.cpp
+ LowerButton.cpp
+ Manager.cpp
+ MaximiseButton.cpp
+ Static.cpp
+ StickyButton.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK kdecorations-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)