summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-10 01:46:23 -0500
committerSlávek Banko <slavek.banko@axis.cz>2012-06-13 21:27:50 +0200
commit4fd3190e4465a5756a953b6beb1ab7b01f6d03aa (patch)
treeafe196aac899640a03a39e3d30e38ca9ce9d1c18 /CMakeLists.txt
parent5a0055f9ddbf20dcca89fef962bccd7c6f225e4a (diff)
downloadtdebase-4fd3190e4465a5756a953b6beb1ab7b01f6d03aa.tar.gz
tdebase-4fd3190e4465a5756a953b6beb1ab7b01f6d03aa.zip
Fix Keramic data file installation and add long long check to CMake
This closes Bug 905 Thanks to Roman Savochenko and Leandro Nini for the patches! (cherry picked from commit dfb75324af3dfdb983f354782c6025f37e665ee5)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d31ade4c1..5f28c9f6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ include( CheckCXXSourceCompiles )
include( CheckLibraryExists )
include( CheckFunctionExists )
include( CheckStructHasMember )
+include( CheckTypeSize )
##### include our cmake modules #################
@@ -152,6 +153,8 @@ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+check_type_size( "long long" LONG_LONG )
+
##### kdebase directories #######################