summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-01-26 21:12:51 +0100
committerSlávek Banko <slavek.banko@axis.cz>2013-01-26 21:16:20 +0100
commit631b41f9a484814e7758f9771ec9af5b7ffd648a (patch)
treec93850e8502d257c576c7088eb4d1d9d1a00b8a9 /CMakeLists.txt
parent3b356437260a9a713d5960d1a26aa30fba40b864 (diff)
downloadtdebase-631b41f9a484814e7758f9771ec9af5b7ffd648a.tar.gz
tdebase-631b41f9a484814e7758f9771ec9af5b7ffd648a.zip
Add CMake option for backtrace in kdesktop_lock exception handler
(cherry picked from commit 936d3cec490c13f2c5f7dd14f5e364fddaa6da71)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27ab130ee..2f16ddc8e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ set( VERSION "3.5.13" )
include( FindPkgConfig )
include( CheckIncludeFile )
+include( CheckIncludeFiles )
include( CheckCSourceRuns )
include( CheckCXXSourceCompiles )
include( CheckLibraryExists )
@@ -79,6 +80,7 @@ option( WITH_XINERAMA "Enable xinerama extension support" OFF )
option( WITH_ARTS "Enable aRts support" OFF )
option( WITH_I8K "Enable Dell laptop support (ksysguard)" OFF )
option( WITH_HAL "Enable HAL support" OFF )
+option( WITH_KDESKTOP_LOCK_BACKTRACE "Enable backtrace in kdesktop_lock exception handler" OFF )
##### user requested modules ####################