summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Andriot <francois.andriot@free.fr>2013-05-05 04:50:18 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-05-05 05:09:58 +0200
commita8fe98ad7575fd44a4b8ae674f51bd328f6cda9a (patch)
treeb5b706c8841eadbb44d8024a91a383bcbe9a39e0 /CMakeLists.txt
parent770eda3afd42b8c3c9ce2775cd6d4a4ef39a6750 (diff)
downloadtdebase-a8fe98ad7575fd44a4b8ae674f51bd328f6cda9a.tar.gz
tdebase-a8fe98ad7575fd44a4b8ae674f51bd328f6cda9a.zip
Added support for makewhatis in tdeio-man
This resolves Bug 714 (cherry picked from commit 2b6bc47289c47d4c5322ac25b688d0b3027a31d0)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0102f7a3c..9339d248f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,6 +220,16 @@ if( BUILD_STARTKDE )
endif()
+##### Determine whether older manpage support is used ##########
+
+if( EXISTS "/usr/sbin/makewhatis" )
+ set( WITH_MAKEWHATIS "1" )
+ message( STATUS "Selected makewhatis for kio-man on your system" )
+else()
+ message( STATUS "Selected man-db for kio-man on your system" )
+endif()
+
+
##### write configure files #####################
configure_file( config.h.cmake config.h @ONLY )