summaryrefslogtreecommitdiffstats
path: root/kate/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-04 06:21:59 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-04 06:21:59 +0000
commitc01c2e1f191c04841f480a1bd768277e7ef4726c (patch)
treec5830d6a065b394969ab6278f0fdb49c69af88ee /kate/Makefile.am
parent65cf1e63bbfb4fe8bede01b16201b624ce78aa88 (diff)
downloadtdebase-c01c2e1f191c04841f480a1bd768277e7ef4726c.tar.gz
tdebase-c01c2e1f191c04841f480a1bd768277e7ef4726c.zip
Repair gcc 4.4 compilation errors
gcc 4.x tries to compile ANY .cpp file, including tips.cpp, so we now generate a tips.txt file instead and use that to generate the .po files git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1069698 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kate/Makefile.am')
-rw-r--r--kate/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/kate/Makefile.am b/kate/Makefile.am
index 9726ea167..4a8b97f91 100644
--- a/kate/Makefile.am
+++ b/kate/Makefile.am
@@ -2,11 +2,11 @@ SUBDIRS = utils interfaces app data pics
EXTRA_DIST = AUTHORS COPYING.LIB ChangeLog DESIGN NEWS README TODO
messages:
- rm -f tips.cpp
- (cd data && $(PREPARETIPS) > ../tips.cpp)
+ rm -f tips.txt
+ (cd data && $(PREPARETIPS) > ../tips.txt)
$(EXTRACTRC) ./*/*.rc >> ./rc.cpp
- $(XGETTEXT) `find . -name "*.cpp"` -o $(podir)/kate.pot
- rm -f tips.cpp
+ $(XGETTEXT) `find . -name "*.cpp" -o -name "*.txt"` -o $(podir)/kate.pot
+ rm -f tips.txt
include ../admin/Doxyfile.am