summaryrefslogtreecommitdiffstats
path: root/kcheckpass/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-08-17 16:25:16 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-08-17 16:25:16 +0200
commit82958c52cc4e119f0f7dbbd6740a4491d383c9aa (patch)
tree53be734807891d04e155313f5f5dcc012dffa281 /kcheckpass/CMakeLists.txt
parentd4f7d3ed42bff12f1533a6ef2715e4c88ed461d2 (diff)
downloadtdebase-82958c52cc4e119f0f7dbbd6740a4491d383c9aa.tar.gz
tdebase-82958c52cc4e119f0f7dbbd6740a4491d383c9aa.zip
Use standard cmake way to install setuid binaries
Diffstat (limited to 'kcheckpass/CMakeLists.txt')
-rw-r--r--kcheckpass/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/kcheckpass/CMakeLists.txt b/kcheckpass/CMakeLists.txt
index 831193d60..5e83ee41e 100644
--- a/kcheckpass/CMakeLists.txt
+++ b/kcheckpass/CMakeLists.txt
@@ -28,7 +28,6 @@ tde_add_executable( kcheckpass AUTOMOC
checkpass_shadow.c checkpass_osfc2passwd.c checkpass_aix.c
LINK tdefakes-shared ${CRYPT_LIBRARY} ${PAM_LIBRARY}
DESTINATION ${BIN_INSTALL_DIR}
+ SETUID
)
-install( CODE "execute_process( COMMAND chown 0 \$ENV{DESTDIR}${_destination}/kcheckpass )" )
-install( CODE "execute_process( COMMAND chmod 4755 \$ENV{DESTDIR}${_destination}/kcheckpass )" )