summaryrefslogtreecommitdiffstats
path: root/kcheckpass/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcheckpass/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcheckpass/Makefile.am')
-rw-r--r--kcheckpass/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kcheckpass/Makefile.am b/kcheckpass/Makefile.am
new file mode 100644
index 000000000..bc8342301
--- /dev/null
+++ b/kcheckpass/Makefile.am
@@ -0,0 +1,26 @@
+## Makefile.am for kcheckpass
+## written by Christian Esken
+##
+
+INCLUDES= $(KDE_USE_FPIE) $(all_includes)
+
+bin_PROGRAMS = kcheckpass
+
+kcheckpass_SOURCES = kcheckpass.c \
+ checkpass_etcpasswd.c checkpass_pam.c checkpass_shadow.c \
+ checkpass_osfc2passwd.c checkpass_aix.c
+kcheckpass_LDADD = -lkdefakes $(PASSWDLIBS) $(LIBSOCKET)
+kcheckpass_LDFLAGS = $(KDE_USE_PIE) $(all_libraries)
+
+noinst_HEADERS = kcheckpass.h
+
+EXTRA_DIST = README
+
+PAM = $(KCHECKPASS_PAM_SERVICE)
+
+install-data-local:
+ -@test -n "$(DESTDIR)" || test -z "$(PAM)" || $(top_srcdir)/mkpamserv $(PAM)
+
+install-exec-hook:
+ @(chown 0 $(DESTDIR)$(bindir)/kcheckpass && chmod 4755 $(DESTDIR)$(bindir)/kcheckpass) \
+ || echo "Error: Could not install kcheckpass as setuid root (possibly you won't be able to unlock)!!"