summaryrefslogtreecommitdiffstats
path: root/kcontrol/energy/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/energy/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/energy/Makefile.am')
-rw-r--r--kcontrol/energy/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kcontrol/energy/Makefile.am b/kcontrol/energy/Makefile.am
new file mode 100644
index 000000000..ea6578582
--- /dev/null
+++ b/kcontrol/energy/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS= . pics
+
+AM_CPPFLAGS = $(all_includes) $(DPMSINC)
+
+kde_module_LTLIBRARIES = kcm_energy.la
+
+kcm_energy_la_SOURCES = energy.cpp
+kcm_energy_la_LDFLAGS = -module -avoid-version $(all_libraries) -no-undefined
+kcm_energy_la_LIBADD = $(DPMSLIB) $(LIB_KDEUI) $(LIB_KIO)
+METASOURCES = energy.moc
+
+noinst_HEADERS = energy.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kcmenergy.pot
+
+energy_data_DATA = energy.desktop
+energy_datadir = $(kde_appsdir)/.hidden