summaryrefslogtreecommitdiffstats
path: root/kcontrol/fonts/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/fonts/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/fonts/Makefile.am')
-rw-r--r--kcontrol/fonts/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kcontrol/fonts/Makefile.am b/kcontrol/fonts/Makefile.am
new file mode 100644
index 000000000..5fe7aa2cf
--- /dev/null
+++ b/kcontrol/fonts/Makefile.am
@@ -0,0 +1,21 @@
+noinst_LTLIBRARIES = libkxftconfig.la
+
+libkxftconfig_la_SOURCES = kxftconfig.cpp
+libkxftconfig_la_LIBADD = $(LIBFONTCONFIG_LIBS)
+libkxftconfig_la_LDFLAGS = $(LIBFONTCONFIG_RPATH)
+
+AM_CPPFLAGS = $(all_includes) $(LIBFONTCONFIG_CFLAGS) $(FREETYPE2_CFLAGS) -D_LARGEFILE64_SOURCE
+
+kde_module_LTLIBRARIES = kcm_fonts.la
+
+kcm_fonts_la_SOURCES = fonts.cpp
+kcm_fonts_la_LDFLAGS = $(KDE_RPATH) $(LIBFONTCONFIG_RPATH) $(FREETYPE2_LDFLAGS) -module -avoid-version $(all_libraries) -no-undefined
+kcm_fonts_la_LIBADD = libkxftconfig.la $(top_builddir)/kcontrol/krdb/libkrdb.la $(LIB_KDEUI) $(LIBFONTCONFIG_LIBS)
+METASOURCES = AUTO
+
+noinst_HEADERS = fonts.h kxftconfig.h
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmfonts.pot
+
+xdg_apps_DATA = fonts.desktop