summaryrefslogtreecommitdiffstats
path: root/kcontrol/hwmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-09-21 15:39:58 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-09-21 15:39:58 -0500
commitb5cb2797d65f2541a4c48ea00e6c325bb375ea46 (patch)
tree61dad727529d9a69977f44a05aca3a719422558c /kcontrol/hwmanager/CMakeLists.txt
parentc73eb5f814d1096cd398fbec3084f816ba8a7269 (diff)
downloadtdebase-b5cb2797d65f2541a4c48ea00e6c325bb375ea46.tar.gz
tdebase-b5cb2797d65f2541a4c48ea00e6c325bb375ea46.zip
Add new hardware device tray application
Allow removable media action request popups to be suppressed
Diffstat (limited to 'kcontrol/hwmanager/CMakeLists.txt')
-rw-r--r--kcontrol/hwmanager/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/kcontrol/hwmanager/CMakeLists.txt b/kcontrol/hwmanager/CMakeLists.txt
index 8b46dd98e..ed63faddb 100644
--- a/kcontrol/hwmanager/CMakeLists.txt
+++ b/kcontrol/hwmanager/CMakeLists.txt
@@ -1,6 +1,6 @@
#################################################
#
-# (C) 2012 Timothy Pearson
+# (C) 2012 - 2015 Timothy Pearson
# kb9vqf (AT) pearsoncomputing.net
#
# Improvements and feedback are welcome
@@ -38,3 +38,13 @@ tde_add_kpart( kcm_hwmanager AUTOMOC
LINK tdeio-shared
DESTINATION ${PLUGIN_INSTALL_DIR}
)
+
+##### tdehwdevicetray (executable) ##############
+
+tde_add_executable( tdehwdevicetray AUTOMOC
+ SOURCES
+ hwdevicetray_main.cpp hwdevicetray.cpp hwdevicetray_app.cpp
+ hwdevicetray_configdialog.cpp
+ LINK tdeio-shared tdeutils-shared tdeui-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+) \ No newline at end of file