summaryrefslogtreecommitdiffstats
path: root/kcontrol/input/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/input/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/input/Makefile.am')
-rw-r--r--kcontrol/input/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/kcontrol/input/Makefile.am b/kcontrol/input/Makefile.am
new file mode 100644
index 000000000..7a852aa3e
--- /dev/null
+++ b/kcontrol/input/Makefile.am
@@ -0,0 +1,47 @@
+if have_xcursor
+THEMEPAGE_SUBDIR = xcursor
+THEMEPAGE_INCLUDES = -I$(srcdir)/xcursor
+THEMEPAGE_LIB = xcursor/libthemepage.la
+else
+THEMEPAGE_SUBDIR = core
+THEMEPAGE_INCLUDES = -I$(srcdir)/core
+THEMEPAGE_LIB = core/libthemepage.la
+endif
+
+SUBDIRS = $(THEMEPAGE_SUBDIR) pics
+
+AM_CPPFLAGS = $(USB_CFLAGS) $(THEMEPAGE_INCLUDES) $(all_includes)
+
+bin_PROGRAMS = kapplymousetheme
+
+kapplymousetheme_SOURCES = kapplymousetheme.cpp
+kapplymousetheme_LDFLAGS = $(all_libraries)
+kapplymousetheme_LDADD = $(LIB_XCURSOR) $(LIB_X11)
+
+kde_module_LTLIBRARIES = kcm_input.la
+
+kcm_input_la_SOURCES = mouse.cpp kmousedlg.ui main.cpp logitechmouse.cpp logitechmouse_base.ui
+kcm_input_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_input_la_LIBADD = $(THEMEPAGE_LIB) $(XTESTLIB) $(LIB_KIO) $(LIB_XCURSOR) $(USB_LIBS)
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp */*.cpp -o $(podir)/kcminput.pot
+
+xdg_apps_DATA = mouse.desktop
+
+fontdir = $(kde_datadir)/kcminput
+font_DATA = cursor_large_black.pcf.gz cursor_large_white.pcf.gz cursor_small_white.pcf.gz
+EXTRA_DIST = $(font_DATA)
+
+update_DATA = mouse_cursor_theme.upd
+
+updatedir = $(kde_datadir)/kconf_update
+
+install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/fonts/override
+ -mkfontdir $(DESTDIR)$(datadir)/fonts/override
+##I'd like to install this automatically, but it only works on Linux, and I don't want to break things...
+## $(INSTALL_DATA) $(srcdir)/consoleUserPerms $(DESTDIR)/etc/hotplug/usb/consoleUserPerms
+## $(INSTALL_DATA) $(srcdir)/logitechmouse.usermap $(DESTDIR)/etc/hotplug/usb/logitechmouse.usermap