summaryrefslogtreecommitdiffstats
path: root/kcontrol/taskbar/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/taskbar/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/taskbar/Makefile.am')
-rw-r--r--kcontrol/taskbar/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kcontrol/taskbar/Makefile.am b/kcontrol/taskbar/Makefile.am
new file mode 100644
index 000000000..bd458e1be
--- /dev/null
+++ b/kcontrol/taskbar/Makefile.am
@@ -0,0 +1,21 @@
+kde_module_LTLIBRARIES = kcm_taskbar.la
+
+kcm_taskbar_la_SOURCES = kcmtaskbarui.ui kcmtaskbar.cpp
+kcm_taskbar_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_taskbar_la_LIBADD = $(top_builddir)/kicker/taskbar/libtaskbar.la -lkdeui
+AM_CPPFLAGS = -I$(top_builddir)/kicker/taskbar $(all_includes)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = kcmtaskbar.h
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmtaskbar.pot
+
+xdg_apps_DATA = kcmtaskbar.desktop
+
+install-data-local: uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(kde_appsdir)/Settings/LookNFeel
+ $(INSTALL_DATA) $(srcdir)/uninstall.desktop $(DESTDIR)$(kde_appsdir)/Settings/LookNFeel/kcmtaskbar.desktop
+
+kcmtaskbar.lo: ../../kicker/taskbar/taskbarsettings.h