summaryrefslogtreecommitdiffstats
path: root/kdesktop/lock/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-04-12 22:29:58 -0500
committerSlávek Banko <slavek.banko@axis.cz>2015-04-14 02:27:26 +0200
commit5d4afcb68fdff18aa9e44d1d111130cdb43e9ba4 (patch)
treeb21fd08b95b326fd66cd59b28022c5a02fa221af /kdesktop/lock/CMakeLists.txt
parent1f266258df399ea64c10001b161a2fb209140b62 (diff)
downloadtdebase-5d4afcb68fdff18aa9e44d1d111130cdb43e9ba4.tar.gz
tdebase-5d4afcb68fdff18aa9e44d1d111130cdb43e9ba4.zip
Remove call to pthread_cancel() in kdesktop_lock
This resolves a sporadic deadlock during kdesktop_lock termination (cherry picked from commit e569dd46ac06ef5a5f2ad03a311640e1834c749f)
Diffstat (limited to 'kdesktop/lock/CMakeLists.txt')
-rw-r--r--kdesktop/lock/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/kdesktop/lock/CMakeLists.txt b/kdesktop/lock/CMakeLists.txt
index 256c6a498..2bbe4b289 100644
--- a/kdesktop/lock/CMakeLists.txt
+++ b/kdesktop/lock/CMakeLists.txt
@@ -38,6 +38,6 @@ set( ${target}_SRCS
tde_add_executable( ${target} AUTOMOC
SOURCES ${${target}_SRCS}
LINK kdesktopsettings-static dmctl-static tdeio-shared Xext
- ${GL_LIBRARIES} "${LINKER_IMMEDIATE_BINDING_FLAGS}"
+ pthread ${GL_LIBRARIES} "${LINKER_IMMEDIATE_BINDING_FLAGS}"
DESTINATION ${BIN_INSTALL_DIR}
)