summaryrefslogtreecommitdiffstats
path: root/khelpcenter/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /khelpcenter/plugins/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'khelpcenter/plugins/CMakeLists.txt')
-rw-r--r--khelpcenter/plugins/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/khelpcenter/plugins/CMakeLists.txt b/khelpcenter/plugins/CMakeLists.txt
index b76a765f1..54b806127 100644
--- a/khelpcenter/plugins/CMakeLists.txt
+++ b/khelpcenter/plugins/CMakeLists.txt
@@ -13,9 +13,12 @@ add_subdirectory( Applications )
add_subdirectory( Manpages )
# add_subdirectory( Scrollkeeper )
-install( FILES
- applets.desktop contact.desktop faq.desktop info.desktop
- links.desktop support.desktop userguide.desktop welcome.desktop
- hardwaremodules.desktop kcontrolmodules.desktop konqplugins.desktop
- tdeioslaves.desktop quickstart.desktop visualdict.desktop adminguide.desktop
- DESTINATION ${DATA_INSTALL_DIR}/khelpcenter/plugins )
+tde_create_translated_desktop(
+ SOURCE
+ applets.desktop contact.desktop faq.desktop info.desktop
+ links.desktop support.desktop userguide.desktop welcome.desktop
+ hardwaremodules.desktop kcontrolmodules.desktop konqplugins.desktop
+ tdeioslaves.desktop quickstart.desktop visualdict.desktop adminguide.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/khelpcenter/plugins
+ PO_DIR khelpcenter-desktops
+)