summaryrefslogtreecommitdiffstats
path: root/khotkeys/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-23 23:42:11 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-23 23:42:11 +0000
commitb6fc43ccd522dfbc1e215b12adb8208c156bbd31 (patch)
treeb6d14378dd6c3d2f74ea8acf515cef7f4a024cb2 /khotkeys/CMakeLists.txt
parentd53bf360906757a36588588fb0286d3b4784ffcb (diff)
downloadtdebase-b6fc43ccd522dfbc1e215b12adb8208c156bbd31.tar.gz
tdebase-b6fc43ccd522dfbc1e215b12adb8208c156bbd31.zip
[kdebase] initial cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1216551 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'khotkeys/CMakeLists.txt')
-rw-r--r--khotkeys/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/khotkeys/CMakeLists.txt b/khotkeys/CMakeLists.txt
new file mode 100644
index 000000000..b2529ae04
--- /dev/null
+++ b/khotkeys/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+check_c_source_runs( "
+ class A { public: virtual A* me(); };
+ class X { public: int x; virtual void ff() {}; };
+ class B : public X, public A { public: virtual B* me(); };
+ int foo( A* a )
+ {
+ A* aa = a->me();
+ return a == aa;
+ }
+ int main()
+ {
+ B* b = new B;
+ return foo( b ) == 0;
+ }
+ A* A::me() { return this; }
+ B* B::me() { return this; }
+" COVARIANT_RETURN )
+
+if( NOT COVARIANT_RETURN )
+ set( COVARIANT_RETURN_BROKEN 1 CACHE INTERNAL "" FORCE )
+endif( )
+
+add_subdirectory( shared )
+add_subdirectory( kcontrol )
+add_subdirectory( app )
+add_subdirectory( data )
+add_subdirectory( update )
+tde_conditional_add_subdirectory( WITH_ARTS arts )
+
+install( FILES khotkeys.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )