summaryrefslogtreecommitdiffstats
path: root/kioslave/filter/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kioslave/filter/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslave/filter/Makefile.am')
-rw-r--r--kioslave/filter/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kioslave/filter/Makefile.am b/kioslave/filter/Makefile.am
new file mode 100644
index 000000000..f315064c8
--- /dev/null
+++ b/kioslave/filter/Makefile.am
@@ -0,0 +1,21 @@
+KDE_CPPFLAGS = -DQT_NO_CAST_ASCII
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kio_filter.la
+
+kio_filter_la_SOURCES = filter.cc
+kio_filter_la_LIBADD = $(LIB_KSYCOCA)
+kio_filter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+noinst_HEADERS = filter.h
+
+METASOURCES = AUTO
+
+protocoldir = $(kde_servicesdir)
+
+if include_BZIP2
+BZIP2FILES=bzip.protocol bzip2.protocol
+endif
+
+protocol_DATA = gzip.protocol $(BZIP2FILES)
+