summaryrefslogtreecommitdiffstats
path: root/kioslave/media/mediamanager/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-03-31 20:18:41 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-03-31 20:18:41 -0500
commit03d905ea268bd893030264b0e7b5b98f783c58ff (patch)
tree3bef5cc590009bc63b9f68a422da1b958c229dcb /kioslave/media/mediamanager/CMakeLists.txt
parentd4e6607ad6a9bfc49f4dfeced379c136704714b1 (diff)
downloadtdebase-03d905ea268bd893030264b0e7b5b98f783c58ff.tar.gz
tdebase-03d905ea268bd893030264b0e7b5b98f783c58ff.zip
Initial merge of alpha quality HAL replacement backend for the media kioslave
Pass the WITH_TDEHWLIB CMake option to enable this backend
Diffstat (limited to 'kioslave/media/mediamanager/CMakeLists.txt')
-rw-r--r--kioslave/media/mediamanager/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/kioslave/media/mediamanager/CMakeLists.txt b/kioslave/media/mediamanager/CMakeLists.txt
index fcd564d43..1c1a076b3 100644
--- a/kioslave/media/mediamanager/CMakeLists.txt
+++ b/kioslave/media/mediamanager/CMakeLists.txt
@@ -9,9 +9,6 @@
#
#################################################
-# FIXME there is no support for HAL and linuxcdpolling yet
-
-
include_directories(
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_BINARY_DIR}/kioslave/media/libmediacommon
@@ -43,7 +40,8 @@ if( WITH_HAL )
mediamanager.cpp mediamanager.skel medialist.cpp
backendbase.cpp fstabbackend.cpp removablebackend.cpp
mediadirnotify.cpp mediadirnotify.skel
- halbackend.cpp linuxcdpolling.cpp
+ decryptdialog.ui dialog.cpp
+ halbackend.cpp linuxcdpolling.cpp tdehardwarebackend.cpp
)
tde_add_kpart( ${target} AUTOMOC
@@ -55,7 +53,8 @@ else( )
set( ${target}_SRCS
mediamanager.cpp mediamanager.skel medialist.cpp
backendbase.cpp fstabbackend.cpp removablebackend.cpp
- mediadirnotify.cpp mediadirnotify.skel
+ decryptdialog.ui dialog.cpp
+ mediadirnotify.cpp mediadirnotify.skel tdehardwarebackend.cpp
)
tde_add_kpart( ${target} AUTOMOC