summaryrefslogtreecommitdiffstats
path: root/konqueror/shellcmdplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /konqueror/shellcmdplugin/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'konqueror/shellcmdplugin/CMakeLists.txt')
-rw-r--r--konqueror/shellcmdplugin/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/konqueror/shellcmdplugin/CMakeLists.txt b/konqueror/shellcmdplugin/CMakeLists.txt
index 6ad36d513..55b32a96d 100644
--- a/konqueror/shellcmdplugin/CMakeLists.txt
+++ b/konqueror/shellcmdplugin/CMakeLists.txt
@@ -24,11 +24,21 @@ link_directories(
##### other data ################################
-install( FILES kshellcmdplugin.rc kshellcmdplugin.desktop
- DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins )
+tde_create_translated_desktop(
+ SOURCE kshellcmdplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins
+ PO_DIR konqueror-desktops
+)
+
+install(
+ FILES kshellcmdplugin.rc
+ DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins
+)
-install( FILES kshellcmdplugin.rc kshellcmdplugin.desktop
- DESTINATION ${DATA_INSTALL_DIR}/konqlistview/kpartplugins )
+install(
+ FILES kshellcmdplugin.rc ${CMAKE_CURRENT_BINARY_DIR}/kshellcmdplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqlistview/kpartplugins
+)
##### konq_shellcmdplugin (module) ##############