summaryrefslogtreecommitdiffstats
path: root/ksplashml/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /ksplashml/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksplashml/Makefile.am')
-rw-r--r--ksplashml/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/ksplashml/Makefile.am b/ksplashml/Makefile.am
new file mode 100644
index 000000000..8e8496db5
--- /dev/null
+++ b/ksplashml/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = themeengine pics kcmksplash
+
+INCLUDES = -I$(srcdir)/themeengine -I$(srcdir)/themeengine/default $(all_includes)
+
+METASOURCES=AUTO
+
+bin_PROGRAMS = ksplash
+ksplash_SOURCES = wndmain.cpp ksplashiface.skel main.cpp
+ksplash_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ksplash_LDADD = $(LIB_KDEUI) themeengine/default/libthemedefault.la themeengine/libksplashthemes.la $(LIB_KIO)
+
+noinst_HEADERS = ksplashiface.h wndmain.h
+
+servicesdir = $(kde_servicesdir)
+services_DATA = ksplash.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp themeengine/*.cpp -o $(podir)/ksplash.pot