summaryrefslogtreecommitdiffstats
path: root/ksplashml/pics/themes/default/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /ksplashml/pics/themes/default/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ksplashml/pics/themes/default/CMakeLists.txt')
-rw-r--r--ksplashml/pics/themes/default/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/ksplashml/pics/themes/default/CMakeLists.txt b/ksplashml/pics/themes/default/CMakeLists.txt
index 6157c39cd..fe70941bc 100644
--- a/ksplashml/pics/themes/default/CMakeLists.txt
+++ b/ksplashml/pics/themes/default/CMakeLists.txt
@@ -9,7 +9,15 @@
#
#################################################
-install( FILES
- Theme.rc Preview.png splash_active_bar.png splash_bottom.png
+tde_create_translated_desktop(
+ SOURCE Theme.rc
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/Default
+ PO_DIR ksplash-themes
+)
+
+install(
+ FILES
+ Preview.png splash_active_bar.png splash_bottom.png
splash_inactive_bar.png splash_top.png
- DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/Default )
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/Default
+)