summaryrefslogtreecommitdiffstats
path: root/ksysguard/example/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /ksysguard/example/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'ksysguard/example/CMakeLists.txt')
-rw-r--r--ksysguard/example/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/ksysguard/example/CMakeLists.txt b/ksysguard/example/CMakeLists.txt
index 7cb6e750f..a275dccfc 100644
--- a/ksysguard/example/CMakeLists.txt
+++ b/ksysguard/example/CMakeLists.txt
@@ -9,5 +9,9 @@
#
#################################################
-install( FILES eventsrc DESTINATION ${DATA_INSTALL_DIR}/ksysguard )
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/ksysguard
+ PO_DIR ksysguard-eventsrc
+)
install( FILES ksysguarddrc DESTINATION ${SYSCONF_INSTALL_DIR} )