summaryrefslogtreecommitdiffstats
path: root/ksysguard/gui/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /ksysguard/gui/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksysguard/gui/Makefile.am')
-rw-r--r--ksysguard/gui/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/ksysguard/gui/Makefile.am b/ksysguard/gui/Makefile.am
new file mode 100644
index 000000000..c0b9d12b3
--- /dev/null
+++ b/ksysguard/gui/Makefile.am
@@ -0,0 +1,63 @@
+
+kdemimedir = $(kde_mimedir)/application
+kdemime_DATA = x-ksysguard.desktop
+
+rcdir = $(kde_datadir)/ksysguard
+rc_DATA = ksysguardui.rc
+
+xdg_apps_DATA = ksysguard.desktop
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = ksysguardapplet.desktop
+
+# claim, which subdirectories you want to install
+SUBDIRS = ksgrd SensorDisplayLib
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(srcdir)/ksgrd -I$(srcdir)/SensorDisplayLib -I$(top_builddir)/ksysguard/gui/SensorDisplayLib $(all_includes)
+
+####### This part is very ksysguard specific
+# you can add here more. This one gets installed
+bin_PROGRAMS = ksysguard kpm
+
+# Which sources should be compiled for ksysguard.
+ksysguard_SOURCES = \
+ SensorBrowser.cc \
+ WorkSheet.cc \
+ WorkSheetSettings.cc \
+ Workspace.cc \
+ ksysguard.cc ksysguard.skel
+
+ksysguard_LDADD = \
+ ksgrd/libksgrd.la \
+ SensorDisplayLib/libsensordisplays.la \
+ $(LIB_KDEUI) $(LIB_KIO) $(LIB_KDNSSD)
+ksysguard_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+kpm_SOURCES = kpm.c
+
+appdatadir = $(kde_datadir)/ksysguard
+appdata_DATA = ProcessTable.sgrd SystemLoad.sgrd KSysGuardApplet.xml
+
+# This stuff is now for the kicker applet
+kde_module_LTLIBRARIES = sysguard_panelapplet.la
+
+sysguard_panelapplet_la_SOURCES = \
+ KSysGuardApplet.cc \
+ KSGAppletSettings.cc
+
+sysguard_panelapplet_la_LIBADD = \
+ ksgrd/libksgrd.la \
+ SensorDisplayLib/libsensordisplays.la \
+ $(LIB_KDEUI) $(LIB_KIO)
+sysguard_panelapplet_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+EXTRA_DIST = $(lnk_DATA)
+
+# just to make sure, automake makes them
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name "*.ui"` >> rc.cpp
+ $(EXTRACTATTR) --attr=display,title SystemLoad.sgrd KSysGuardApplet.xml >> rc.cpp
+ $(XGETTEXT) `find . -name "*.cpp" -o -name "*.cc"` -o $(podir)/ksysguard.pot