summaryrefslogtreecommitdiffstats
path: root/ksysguard/ksysguardd/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-08-27 06:21:51 +0400
committerSlávek Banko <slavek.banko@axis.cz>2013-09-08 10:50:40 +0200
commit84d73a40b2cca0c3f6cac9e50712cb51cbc1b648 (patch)
treea019d70bdb17c8d56499d9f704d323e074178db1 /ksysguard/ksysguardd/CMakeLists.txt
parent54ebc6da596d3664170e0537e444ba6879fb2af7 (diff)
downloadtdebase-84d73a40b2cca0c3f6cac9e50712cb51cbc1b648.tar.gz
tdebase-84d73a40b2cca0c3f6cac9e50712cb51cbc1b648.zip
Add lm_sensors optional support for ksysguard
Diffstat (limited to 'ksysguard/ksysguardd/CMakeLists.txt')
-rw-r--r--ksysguard/ksysguardd/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/ksysguard/ksysguardd/CMakeLists.txt b/ksysguard/ksysguardd/CMakeLists.txt
index 030700f49..9ec73cc93 100644
--- a/ksysguard/ksysguardd/CMakeLists.txt
+++ b/ksysguard/ksysguardd/CMakeLists.txt
@@ -11,13 +11,14 @@
# FIXME there is only Linux support
+include( ConfigureChecks.cmake )
+
if( ${CMAKE_SYSTEM_NAME} MATCHES "Linux" )
set( OS_SPECIFIC_DIR Linux )
else()
tde_message_fatal( "Your operating system (${CMAKE_SYSTEM_NAME}) is not supported yet." )
endif()
-
add_subdirectory( ${OS_SPECIFIC_DIR} )
@@ -39,5 +40,6 @@ include_directories(
tde_add_executable( ksysguardd AUTOMOC
SOURCES Command.c conf.c ksysguardd.c PWUIDCache.c
LINK ccont-static ksysguardd-static ${TDE_LIB_DIR}/libtdefakes_nonpic.a
+ ${SENSORS_LIBRARIES}
DESTINATION ${BIN_INSTALL_DIR}
)