summaryrefslogtreecommitdiffstats
path: root/ksysguard/ksysguardd/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /ksysguard/ksysguardd/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksysguard/ksysguardd/Makefile.am')
-rw-r--r--ksysguard/ksysguardd/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/ksysguard/ksysguardd/Makefile.am b/ksysguard/ksysguardd/Makefile.am
new file mode 100644
index 000000000..485700780
--- /dev/null
+++ b/ksysguard/ksysguardd/Makefile.am
@@ -0,0 +1,35 @@
+AUTOMAKE_OPTIONS = foreign
+
+if include_ksysguardd_linux
+linux_SUBDIR = Linux
+endif
+if include_ksysguardd_freebsd
+freebsd_SUBDIR = FreeBSD
+endif
+if include_ksysguardd_netbsd
+netbsd_SUBDIR = NetBSD
+endif
+if include_ksysguardd_solaris
+solaris_SUBDIR = Solaris
+endif
+if include_ksysguardd_tru64
+tru64_SUBDIR = Tru64
+endif
+if include_ksysguardd_irix
+irix_SUBDIR = Irix
+endif
+if include_ksysguardd_openbsd
+openbsd_SUBDIR = OpenBSD
+endif
+
+SUBDIRS = $(linux_SUBDIR) $(freebsd_SUBDIR) $(netbsd_SUBDIR)\
+ $(solaris_SUBDIR) $(tru64_SUBDIR) $(irix_SUBDIR) $(openbsd_SUBDIR)
+
+KSYSGUARDDRCFILE=$(sysconfdir)/ksysguarddrc
+INCLUDES = -DKSYSGUARDDRCFILE="\"$(KSYSGUARDDRCFILE)\"" -DOSTYPE_$(UNAME) -I$(srcdir)/../CContLib -I$(srcdir)/$(UNAME) $(all_includes)
+
+bin_PROGRAMS = ksysguardd
+
+ksysguardd_SOURCES = Command.c conf.c ksysguardd.c PWUIDCache.c
+ksysguardd_LDFLAGS = $(all_libraries)
+ksysguardd_LDADD = $(top_builddir)/ksysguard/ksysguardd/$(UNAME)/libksysguardd.a ../CContLib/libccont.a -lkdefakes_nonpic $(LIBHOSTS) $(LIB_DNSSD) $(LIB_KINFO)