summaryrefslogtreecommitdiffstats
path: root/ktip/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /ktip/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ktip/CMakeLists.txt')
-rw-r--r--ktip/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/ktip/CMakeLists.txt b/ktip/CMakeLists.txt
index 350cb8881..8c1e08749 100644
--- a/ktip/CMakeLists.txt
+++ b/ktip/CMakeLists.txt
@@ -25,8 +25,11 @@ link_directories(
##### other data ################################
tde_install_icons( )
-install( FILES ktip.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES ktip.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
+tde_create_translated_desktop( ktip.desktop )
+install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/ktip.desktop
+ DESTINATION ${AUTOSTART_INSTALL_DIR}
+)
install( FILES uninstall.desktop DESTINATION ${APPS_INSTALL_DIR}/Toys RENAME ktip.desktop )
install( FILES tips DESTINATION ${DATA_INSTALL_DIR}/tdewizard )