summaryrefslogtreecommitdiffstats
path: root/kwin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kwin/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kwin/Makefile.am')
-rw-r--r--kwin/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/kwin/Makefile.am b/kwin/Makefile.am
new file mode 100644
index 000000000..c652c81e9
--- /dev/null
+++ b/kwin/Makefile.am
@@ -0,0 +1,38 @@
+INCLUDES = -I$(srcdir)/lib $(all_includes)
+
+if include_kompmgr
+KOMPMGR=kompmgr
+endif
+
+SUBDIRS = lib . killer kcmkwin pics clients oldheaders data $(KOMPMGR)
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kwin.la
+
+kwin_la_SOURCES = workspace.cpp client.cpp placement.cpp atoms.cpp \
+ utils.cpp layers.cpp main.cpp popupinfo.cpp tabbox.cpp \
+ options.cpp plugins.cpp events.cpp KWinInterface.skel \
+ killwindow.cpp geometrytip.cpp sm.cpp group.cpp bridge.cpp \
+ manage.cpp notifications.cpp activation.cpp useractions.cpp \
+ geometry.cpp rules.cpp
+
+kwin_la_LIBADD = $(LIB_KDEUI) lib/libkdecorations.la
+kwin_la_LDFLAGS = $(all_libraries) -module -avoid-version
+
+include_HEADERS = KWinInterface.h
+
+KDE_ICON = kwin
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) -kaliasLocal *.h *.cpp killer/*.cpp lib/*.cpp -o $(podir)/kwin.pot
+
+kwin_datadir = $(kde_datadir)/kwin
+
+kwin_data_DATA= eventsrc
+
+kde_kcfg_DATA = kwin.kcfg
+
+include ../admin/Doxyfile.am