summaryrefslogtreecommitdiffstats
path: root/kwin/clients/plastik/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kwin/clients/plastik/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kwin/clients/plastik/Makefile.am')
-rw-r--r--kwin/clients/plastik/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kwin/clients/plastik/Makefile.am b/kwin/clients/plastik/Makefile.am
new file mode 100644
index 000000000..78e71f763
--- /dev/null
+++ b/kwin/clients/plastik/Makefile.am
@@ -0,0 +1,19 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+kwindir = $(kde_datadir)/kwin/
+kwin_DATA = plastik.desktop
+
+kde_module_LTLIBRARIES = kwin3_plastik.la
+kwin3_plastik_la_SOURCES = plastik.cpp plastikclient.cpp plastikbutton.cpp misc.cpp
+kwin3_plastik_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kwin3_plastik_la_LIBADD = $(LIB_KDEUI) ../../lib/libkdecorations.la
+kwin3_plastik_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(kwin3_plastik_la_METASOURCES)
+