summaryrefslogtreecommitdiffstats
path: root/nsplugins/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /nsplugins/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'nsplugins/Makefile.am')
-rw-r--r--nsplugins/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/nsplugins/Makefile.am b/nsplugins/Makefile.am
new file mode 100644
index 000000000..71c23d69f
--- /dev/null
+++ b/nsplugins/Makefile.am
@@ -0,0 +1,37 @@
+SUBDIRS = viewer test
+INCLUDES = -I$(top_srcdir)/libltdl $(all_includes)
+METASOURCES = AUTO
+noinst_HEADERS = nspluginloader.h
+
+NSPluginClassIface_DIR = $(srcdir)/viewer
+
+kde_module_LTLIBRARIES = libnsplugin.la kcm_nsplugins.la
+libnsplugin_la_SOURCES = plugin_part.cpp nspluginloader.cpp \
+ NSPluginClassIface.stub \
+ NSPluginCallbackIface.skel
+
+libnsplugin_la_LDFLAGS = $(all_libraries) -avoid-version -module $(KDE_PLUGIN) -no-undefined
+libnsplugin_la_LIBADD = -lkparts
+
+bin_PROGRAMS = nspluginscan
+nspluginscan_SOURCES = pluginscan.cpp
+nspluginscan_LDFLAGS = $(KDE_RPATH) $(all_libraries) -export-dynamic
+nspluginscan_LDADD = $(LIB_KDEUI) $(LIB_KSYCOCA) -lXt libpluginpaths.la
+
+kcm_nsplugins_la_SOURCES = kcm_nsplugins.cpp
+kcm_nsplugins_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_nsplugins_la_LIBADD = $(LIB_KDECORE) libpluginpaths.la
+
+noinst_LTLIBRARIES = libpluginpaths.la
+libpluginpaths_la_SOURCES = plugin_paths.cpp
+
+xdg_apps_DATA = khtml_plugins.desktop
+
+partrcdir = $(kde_datadir)/plugin
+partrc_DATA = nspluginpart.rc
+
+messages: rc.cpp
+# $(EXTRACTRC) `find . -name "*.ui"` >> rc.cpp
+ $(EXTRACTRC) `find . -name "*.rc"` >> rc.cpp
+ $(XGETTEXT) *.cpp viewer/*.cpp -o $(podir)/nsplugin.pot
+