summaryrefslogtreecommitdiffstats
path: root/nsplugins/viewer/CMakeLists.txt
diff options
context:
space:
mode:
authorFrançois Andriot <francois.andriot@free.fr>2014-10-12 18:24:29 +0200
committerSlávek Banko <slavek.banko@axis.cz>2014-10-12 18:50:07 +0200
commitbfbcf19a2fbfa301b8796f19b71fdee3e8c4fce6 (patch)
tree2e35f9ade51f07e6ef009bf7b3fdfcce106e99de /nsplugins/viewer/CMakeLists.txt
parent56c4daef68fee06d34ac5021b64a0d8bd454b106 (diff)
downloadtdebase-bfbcf19a2fbfa301b8796f19b71fdee3e8c4fce6.tar.gz
tdebase-bfbcf19a2fbfa301b8796f19b71fdee3e8c4fce6.zip
Fix hardcoded link flag to "dl" library
Fix "dlopen" function detection
Diffstat (limited to 'nsplugins/viewer/CMakeLists.txt')
-rw-r--r--nsplugins/viewer/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/nsplugins/viewer/CMakeLists.txt b/nsplugins/viewer/CMakeLists.txt
index 89e0ef32b..e3149cadb 100644
--- a/nsplugins/viewer/CMakeLists.txt
+++ b/nsplugins/viewer/CMakeLists.txt
@@ -30,6 +30,6 @@ tde_add_executable( nspluginviewer AUTOMOC
../NSPluginCallbackIface.stub NSPluginClassIface.skel
nsplugin.cpp viewer.cpp qxteventloop.cpp
glibevents.cpp
- LINK tdeparts-shared tdeio-shared ${GLIB2_LIBRARIES} Xt dl
+ LINK tdeparts-shared tdeio-shared ${GLIB2_LIBRARIES} Xt ${DL_LIBRARIES}
DESTINATION ${BIN_INSTALL_DIR}
)