summaryrefslogtreecommitdiffstats
path: root/tdeprint/slave/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
commitb529f046c9a64ac5fcfa60747af940cf972b3ebc (patch)
tree83c28cf7fa8fed1960ebd3924b579e7ed8c95cc6 /tdeprint/slave/Makefile.am
parent6508fe4c40c60fd7a43bd3d9e19b762e10ea3f53 (diff)
downloadtdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.tar.gz
tdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/slave/Makefile.am')
-rw-r--r--tdeprint/slave/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdeprint/slave/Makefile.am b/tdeprint/slave/Makefile.am
new file mode 100644
index 000000000..5e5e04123
--- /dev/null
+++ b/tdeprint/slave/Makefile.am
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+SUBDIRS = mimetypes templates
+
+INCLUDES= $(all_includes)
+
+kde_module_LTLIBRARIES = kio_print.la
+
+kio_print_la_SOURCES = kio_print.cpp
+kio_print_la_LIBADD = $(LIB_KIO) -ltdeprint
+kio_print_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = kio_print.h
+
+# Services
+servicesdir = $(kde_servicesdir)
+services_DATA = print.protocol printdb.protocol
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kio_print.pot