summaryrefslogtreecommitdiffstats
path: root/tqt3integration/module/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /tqt3integration/module/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'tqt3integration/module/CMakeLists.txt')
-rw-r--r--tqt3integration/module/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tqt3integration/module/CMakeLists.txt b/tqt3integration/module/CMakeLists.txt
index dd7a62ebe..2cc62f246 100644
--- a/tqt3integration/module/CMakeLists.txt
+++ b/tqt3integration/module/CMakeLists.txt
@@ -24,7 +24,12 @@ link_directories(
##### service desktop file(s) ##########################
-install( FILES kdeintegration.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+tde_create_translated_desktop(
+ SOURCE kdeintegration.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+ PO_DIR tdeintegration.desktop
+)
+
##### kded_kdeintegration (module) #####################